Jump to content

Brads Cut Bait Plug - What is that smell?


Recommended Posts

Just in case you leave the tuna in your cut bait plug, here is a helpful hint so do not have to toss out the plug.

I know no one ever forgets to clean up the cut bait plugs on purpose. I guess learned the smelly way! Tuna gets to stinking bad especially when you leave it in your live well where it is alway damp! :eek:

Just in case you are just as forgetful as I am. The bad scent gets imbedded into the plastic of the body! You should not run the plug all stinky, you never want to be the stinky kid! No need to toss em out, just descent them. This will not harm the finish or the line. Here is the fix.

First clean out the remaining tuna, it will be dry but extremely ripe. Next fill a large glass with hot tap water, 120 degree is fine. Now add a 1/3 to 1/2 cup of baking soda. Mix and then drop in the cut bait plug. Make sure you drop in the rubber tubing band and the leader. Let it soak overnight. Presto no more stinko. :thumb:

Works on meat rigs too!

Remember those salmon are like blood hound with fins!

Link to post
Share on other sites
even worse I had forgot the tuna in the container, it was like a bad chemistry experiment !

Needed Gloves a mask and a paper bag to yak in.

I don't care who you are, that's funny. :lol:

Link to post
Share on other sites
I had a quart of oil leak and get on a couple spoons and flies. Mabey i should try this with them?

Joe, it is worth a try. You may need to soak them several times and go heavy on the baking soda!

Link to post
Share on other sites

this may not be the right place for this post .but here goes i have some of the brads cut baits and tried them last year every time i did i had a huge tangle in fact the only tangles i had last year that did not invole fish on the line i tried diffrent swivels and tried tied direct did not matter what i did .any thoughts on what was wrong i only tried them on riggers and i did not put them behind flashers or dodgers was going to toss them but have not yet any thoughts on what i am doing wrong.

Link to post
Share on other sites

I normally dont buy the pre rigged packs of the cut plugs but when I have no other choice the first thing I do is cut down the 300' of leader they give you. I run a 18-24" leader. I run them clean like a spoon normally no fancy flasher for me. The long leader may be causing your issues, and just like everything, delpoy them slowly.

Also I get rid of the cheap hooks and throw on a VMC hok.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...