Jump to content

Recommended Posts

We picked up a SubTroll at the GR Sport Fishing show and I was in the boat yesterday trying to figure out just where I wanted to put it... So...

Anyone have any tips on mouting a SubTroll? I know the basics and I can read the directions, what i'm looking for is things like 'oh I did this and then wished I hadn't' etc... Just practical advice.

Also, thoes of you who have them are you useing the coated cable that is included?

Thanks.

Link to post
Share on other sites

Mine comes in next week, so I'll be interested in the replies to this tread.

The coated cable is a must. They will work with out it but, only down to a certain depth (60-80'?) here's a pick on the ends for your coated cable.

4622e7fe16104e5a.jpg

Ken.

Link to post
Share on other sites

I put one on my boat last year. If you crimp the cable using the crimps that are provided be sure to use the proper crimp tool. A pair of pliars will not work. I do use the coated cable, it was not difficult to change the cable.

Link to post
Share on other sites

i have the moor sub troll 900 and a complete set of instructions if ya need a copy let me no i installed it to the rigger already,coated cable and the release i just drilled out the lower rivet and installed a small stainless steel screw and a nyloc nut.you have to burn the coating off the first six feet of the coated cable and sand shiney,light the end and let it burn like a candle then install coated cable,make sure you pass it threw the atenna pick up spring before you put on the release,let me know if ya need more help

Link to post
Share on other sites

I have a Depth Raider and installed it exactly as the directions showed.

One good tip is spraying the coated cable with armor all to prevent wear to the coating.

Another tip is to place the probe on a rigger that will not be the deepest. Use it on a mid-range rigger so the chances of getting it caught on the bottom are minimal.

It can always find a net though!

-Kevin-

Link to post
Share on other sites
  • 3 weeks later...

we mounted our unit and probe this weekend. I just stuck with the instructions and am fairly convident in our crips on the included cable terminator. Just to apise myself I have it hanging in the bard right now with my heaviest weight attached to it. Can't wait to get it in the water and start useing it now!

Thanks for the feedback, sounds like several of us have picked up probes for this season!

Link to post
Share on other sites

ive talked to the big guy at depth raider and he said he had reports of guys attaching the probe via the removeable meathode and NOT using the rubber tape to insulate it and he noted that NO sigal was lost down to 150FOW. i myself dont let my probe go that deep but i as well didnt use the tape and attached mine to be removeable and not lost signal

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...