Vanj85

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

10 Good

About Vanj85

  • Rank
    Fisherman
  1. Megabyte offered to try it this weekend, thanks everyone for their input Sent from my SM-G900V using Great Lakes Fisherman Mobile App
  2. It's free if in warrenty, they already sent a new head unit to try, but it didn't fix everything. Sent from my SM-G900V using Great Lakes Fisherman Mobile App
  3. It's still under warrenty, i'll p.m. you contact info in a little bit Sent from my SM-G900V using Great Lakes Fisherman Mobile App
  4. I need someone willing to try my probe out it is not reading properly. I have tried everything to trouble shoot, including but not limited to, new display, transducer angle, dedicated electronics battery, resistor plugs, and not moving to see if I get down temp and nothing. Display says low batteries, yes I have put multiple sets of batteries in, and doesn't have down depth temp or speed. Every once in a while it will show speed and temp quick but will be off on both. I have top speed and temp just nothing down. I've turned gain up and down also. I just need someone who works, lives, or plays in grand rapids or muskegon to use my probe with their unit so I can see if it's transducer or probe issue. Thanks in advance. Sent from my SM-G900V using Great Lakes Fisherman Mobile App
  5. I fished the afternoon., nothing in 20-50, moved out to 160-200 took 4 coho missed 4. Most hits were around 150 fow 50 down wire divers were the ticket. Saw a few guys working the pier on my way out. Sent from my SM-G900V using Great Lakes Fisherman Mobile App
  6. Cannon down rigger issues

    Sounds like an underlying problem. I had unitrolls and never had an issue, upgraded over the winter to electric and couldn't be happier. I'd look for the cause of the problem not the result.