Jump to content

Ken

Members
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

11 Good

About Ken

  • Rank
    Fisherman
  • Birthday 01/10/1968

Personal Information

  • Real Name
    Ken
  • Biography
    I hunt and fish......muscle cars ( i own a 67 mustang coupe)......and trucks....
  • Location
    Pa
  • Interests
    fishing/hunting/cars.....etc
  • Occupation
    Sign tech
  1. well, its been a while.......... finally got the boat running........... new ignition switch, etc............... lasted a season and a half............. started running rough, tapping to beat the band..........so........ found this. machine shop did a .4000th overbore... and its now going back together again............ question, does ANYONE have a pic or 2 of a 1992 Mercruiser showing the hoses and other stuff, ya know, pics of the motor assembled? thanks Guys.
  2. Checked the dist cap today.............. this is what i found.......won't let me add pics.............wtf?
  3. Here i am! Had the D/R starter rebuilt AND purchased a new starter.... the boat cranks over great......... but still won't fire........... a touch of ether in the carb, and still nothing..........never had this issue before, could it be the distributer cap? I appreciate all the help guys...........gotta get my dad out on the water before the end of the summer....
  4. Ok, update........... new starter........ had the old one tested.....junk....... new ignition switch,fresh batteries.......new 50 amp breaker............turn the key,the boat turns over great, just won't fire....... going to check the dis cap tomorrow....... check for spark..... man i'm running out of time.............
  5. OK, i'm confused. Still having starting issues......... checked the cables, good, batteries,good.......new ignition switch..................solenoid is good........ pulled my starter and had it checked at Advance Auto, barely turned over......,then stopped completely............ trying to find a replacement online......... can someone help me on this? I have a 1992 Glasport 22' fishing boat......... it's a 4.3 mercruiser I/O. The ones i'm finding, say 1996 and up.... the one i have is a Delco Remy 9000762 i believe........
  6. Jumped solenoid,with key on..boat turned over and actually started. Shut it off and turned key no click just silence...guessing ignition switch is the problem.50 amp breaker looks like it tripped,but can't tell. Gonna replace it .
  7. Brand new cables both sides......... battery terminals were cleaned and greased..It's getting power, just won't turn over.going to try to jump the solenoid.....
  8. the batteries i have ,use the small post/wing nut set up, great for solid hook ups............
  9. Tried that............ when the key is turned, it clicks, just once.......... going to try to jump the solenoid tomorrow....... hoping it's not the starter, but due to the crappy boat cover i had, it filled with water,when ,when i took it off, sent the water towards the stern of the boat.......... a LOT of water.
  10. Went to start my boat.......solenoid clicks....nothing happens......... newer starter 2 years ago....... batteries are fully charged. And ideas? Guessing the solenoid or the starter..........
  11. now, i either have to find a pigtail for the Raytheon fish finder or try to figure out a way to remove the fishfinder and it's 50+ feet of cable, and install a Hummingbird in it's place...........
  12. Anyone have a suggestion? Seems my L750 doesn't run right.........sounds stupid,but i have dual batteries on my boat, for some reason i kept starting it with just one battery switched on, (stupid mistake)......but when the fishfinder was on it would flash either 00 or 99.......thinking that when the voltage isn't right,the fishfinder won't work right.the problem is, i seem to have lost the pigtail from the fishfinder, i know the history of the raytheon L750 isn't the greatest but i can't troubleshoot the problems without the pigtail.can anyone help me out here?
  13. Ok, new problem, my boat is set up with a Raytheon fishfinder.......... ell it crapped out, still displays but flashes and doesn't show depth or anything, wanna replace it with a Hummingbird. but can't seem to figure out how to pull the cable out
×
×
  • Create New...