Jump to content

Recommended Posts

I just purchased a boat with a Sub-Troll 900, that is probably from 1990s. Hoping someone could help me with a couple questions:

1) Does anyone have a manual for the Sub-Troll 900 that they could share. Checked out the "Zip File" in another thread, however it is no longer active.

2) Also wondering if it is normal to see no temperature reading when the probe is out of the water. When I power up the unit in my garage, all I see is the decimal point on the display. I assumed it would read/display the ambient air temp???

Thanks for any help!

Share this post


Link to post
Share on other sites

Should not show temp out of the water, should just show decimal point. I'll see if I can find my manual. Pretty simple though. Make sure you open and disconnect battery if your not using it for awhile. Also check O ring make sure it's in good shape, and lube with vasoline. If it needs replacement get it from them. I calibrated my speed about 1' down in a no current condition, using my GPS that way I know any difference from GPS speed when I'm using it is a +/- current.

Share this post


Link to post
Share on other sites

Thanks for the quick reply...

LOL, I didn't even know there was a battery or o-ring. Is that in the sensor/probe? If so, how do you access it? Thanks again!

Share this post


Link to post
Share on other sites

Looked at the sup-troll again last night and found the cap at the end of the probe. Removed the battery and checked the o-ring as you suggested. Thanks again!

Any help on the manual will be truly appreciated!

Chris

Share this post


Link to post
Share on other sites

make sure print has a good coat of vasoline on it when you put it back on. I leave mine just screwed on by 1 or 2 threads when not being used. Here is a copy of the manual sorry they are pictures but my copier is a pain. good luck and leave some fish out there for me.

post-5323-14498788235405_thumb.jpg

Share this post


Link to post
Share on other sites

FYI     Apparently Subtroll has gone out of business. However, the former owner attended the LOTSA Show in Niagra Falls last weekend and announced that he still carries parts and does maintenance on the units.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...